Author Topic: Kiss set up motors twitch when arm  (Read 1473 times)

Offline gatormurica

  • Drinks Maker
  • *
  • Posts: 1
  • Karma: +0/-0
  • rookie
    • View Profile
Kiss set up motors twitch when arm
« on: February 05, 2018, 07:53:33 PM »
I have been building my first quad and I am loving it.  Unfortunately, I have hit a bit of a roadblock.  Here is what I am using and running.  Kiss FC, Kiss escs, 1200 kV motors,  x4r sbus.  I am using dshot 600. 

When I plug in my battery into my quad and hit my arm switch my motors turn on and they appear to spin up together at the same time.  There is no jittering in the motors.  When I put a set of props on the motors, certain motors start to jitter when I arm.  This only happens when I have my props on.  When there is tape on my motor shafts this doesn't happen.  Is only happens to one motor at a time.  Sometimes it goes to a different motor.

This has been confusing me for a while now.  I have checked my solder points on my esc's for shorts.  I have also increased my speed of the motors at which I arm my drone at.  None of this has worked.  I have uploaded my firmware through the kiss gui.  I have been told that dshot does do not need calibration.  Is there some sort of calibration that dshot does need? What should I do to expose this problem?  What could it be?  If anyone out there sees this and has any sort of advise I would be grateful to hear you out.  Thank you,

Offline scousethief

  • Drinks Maker
  • *
  • Posts: 9
  • Karma: +0/-0
  • rookie
    • View Profile
Re: Kiss set up motors twitch when arm
« Reply #1 on: February 06, 2018, 12:15:12 PM »
I know youve already done it, but, the first thing to check is that your stick commands correspond to what you see in the Gui and that the FC is set to your RX type ( ibus/sbus etc ), next check the motors min throttle value and make sure the correct flight modes are selected. Then i would lower Dshot to something simpler like one shot or even PWM and see if that changes anything.

When you say you put tape on the motor shaft do you mean underneath the motor inbetween the frame arm and the motors base ? tape on the shaft shouldnt really do anything. I would take all 4 motors off the frame and solder them in one by one checking they respond via the TX as you go buy swapping the motors over ie front left becomes rear right.

The motors glitching is usually a soldering issue or a signal/PPM/Ibus/etc or Dshot/multishot/oneshot incompatibility.

I would also try soldering in a different motor on one of the escs just to rule out a batch of flaky motors.


Offline TranLauril

  • Drinks Maker
  • *
  • Posts: 2
  • Karma: +0/-0
  • rookie
    • View Profile
Re: Kiss set up motors twitch when arm
« Reply #2 on: April 19, 2019, 08:11:11 AM »
Hindi ko alam kung gaano karaming mga pag-update ang ginawa upang hindi ako makatutulong sa pagrerekomenda sa kanila.

Offline toytoyslim

  • Drinks Maker
  • *
  • Posts: 2
  • Karma: +0/-0
  • rookie
    • View Profile
Re: Kiss set up motors twitch when arm
« Reply #3 on: May 15, 2019, 05:34:21 AM »
Actually, you should have better questions.